PhpMyVisites



  • Bonjour,

    J'ai mis phpMyVisites sur mon site, mais j'ai remarqué une chose étrange.

    A l'adresse http://ns6.freeheberg.com/~war/ => le logo de phpMyVisites s'affiche bien en bas à droite et les stats fonctionnent bien.
    A l'adresse http://war.freeheberg.com => le logo de phpMyVisites ne s'affiche pas et aucune données de stats fonctionnent!
    Sachant que je viens d'acheter un nom de domaine, en théorie il sera redirigé vers ns6.freeheberg.com/~war donc je ne devrais avoir aucun problème.
    Donc ma question est la suivante, pourquoi sur les sous-domaine de FreeHeberg ce modules de stats ne fonctionne pas?



  • Tres probablement pour eviter les "fausses" visites.
    Regarde si une option de configuration ne te permet pas de l'activer meme lorsque la page chargee est une iframe.



  • aucune option de ce style, mais je pense que c'est du au sous-domaine FreeHeberg.

    Code source de la page de sous-domaine, les iframes doivent tout clapoter !

    <html>
            <head>
                    <title>http://war.freeheberg.com</title>
                    <meta name="generator" content="ORT - Ovh Redirect Technology">
                    <meta name="url" content="ns6.freeheberg.com/~war/">
                    <meta name="robots" content="all">
            </head>
            <frameset rows="100%,0" frameborder=no border=0>
    
                    <frame name="ORT" src="http://ns6.freeheberg.com/~war/">
                    <frame name="NONE" src="" scrolling="no" noresize>
                    <noframes>
                            <body><a href="http://ns6.freeheberg.com/~war/">Click here</a><hr></body>
                    </noframes>
            </frameset>
    </html>
    

  • Administrateur

    C'est un bug récurent de phpmyvisite qui a été signalé de nombreuses fois au développeur mais celui ci ne tenant plus le script à jour, il n'y a pas de solution, à part acheter un nom de domaine :)



  • Ok, je vais tester SpongeStats. pour les personnes qui n'utiliseront pas mon nom de domaine.



  • En effet, ça doit être un bug de phpMyVisites car SpongeStats fonctionne trés bien avec le sous-domaine. Je recommande d'ailleurs, super simple d'utilisation


Log in to reply