Vhost



  • Bonjour,

    J'ai le nom de domaine 'OverBlogs.fr" et sur mon serveur, le site se trouve dans /var/www/overblogs mais le serveur apache est /var/www

    J'ai tenté de règler avec un VHost, mais apache2 ne redémarre plus :

    NameVirtualHost overblogs.fr
    <VirtualHost overblogs.fr:80>
            ServerName "overblogs.fr:80" # nom du Vhost
            DocumentRoot "/var/www/OverBlogs/" # emplacement des fichiers
    
            <Directory "/home/www/OverBlogs/"> # options d'accès
                    Options Indexes FollowSymLinks MultiViews # index automatiques
                    AllowOverride None # on ne tient pas compte des .htaccess
                    Order allow,deny
                    allow from all # autorisation d'accès à tout le monde
                    allow from .overblogs.fr
            </Directory>
    </VirtualHost>
    
    

    J'ai ce message d'erreur :

    root@overblogs:/# /etc/init.d/apache2 restart
     * Restarting web server apache2                                                Syntax error on line 3 of /etc/apache2/sites-enabled/000-default:
    ServerName takes one argument, The hostname and port of the server
                                                                             [fail]
    
    


  • Truc bête: pourquoi tu ne déplace oas le contenu du dossier overblog dans www ?



  • car je compte héberger d'autres site et d'autre domaine.

    Sinon là j'ai règlé le problème, mais maintenant j'ai une page blanche et quand j'appel un fichier, il me propose de le télécharger. Meme une page .html…



  • Encore mieux, en fait je ne voit toujours pas mon host… en y regardant, j'ai viré ma configuration de vhost et ça ne change rien.

    ça fait 24h, j'ai encore 48 h a attendre :)



  • C'est règlé, la propagation des dns est enfin finie.

    Maintenant le site fonctionne mais il ne me permet pas de généré des sous-domaines automatiquement… :'(


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.