Erreur "unexpected T_STRING" à la publication



  • Bonjour à tous,

    Voila, je crée mon site à l'aide d'iweb, sur mac.

    Les pages générées le sont en html, et la première ligne de chaque page est :"<?xml version="1.0" encoding="UTF-8"?> "

    Or, cette ligne provoque une erreur "unexpected T_STRING" une fois le site publié sur freeheberg (cela fonctionne bien en local).

    J'ai cru comprendre qu'il y avait une mauvaise interprétation PHP de la part du serveur …

    Sinon, j'ai tenté d'insérer un fichier .htaccess contenant "php_flag short_open_tag off" ou "php_value short_open_tag 0"

    Mais cela occasionne cette erreur :
    "Internal Server Error - The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, postmaster@ns9.freeheberg.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log."

    Y a il une solution pour résoudre ce problème ? (à part enlever cette ligne sur toutes les pages ….)
    Merci ! :wink:


  • Administrateur

    Non, on autorise le short tag car la majorité des webmasters ont la flemme de faire le <?php complet.
    Et pour ne pas permettre de bloquer la publicité automatique, on empêche la modification du php.ini via un .htaccess.

    Donc, comme tu l'aura deviné, la seule solution est d'enlever le <?xml qui en terme de code ne sert strictement à rien ! (excepté pour savoir avec quoi on bosse, mais 100 % des navigateurs savent sur quoi on bosse donc pas besoin de le préciser).

    On peux me sortir la règle de compatibilité xhtml, mais personnellement, cette règle ne vaut rien sur un site puisque dans tous les cas, google vous comprendra, et les navigateurs vous comprendront. :)



  • OK, merci pour votre réponse …

    Mince alors, je dois me séparer d'iWeb ?
    Dommage ...

    Pour info, aurais-je le même soucis avec rapiweaver à votre avis ?



  • La solution serait de bidouiller le code pour faire écrire cette ligne a php:

    remplace

    <?xml
    

    Par

    <?php echo '<?xml'; ?>
    

    Mais faut bidouiller …



  • Merci,

    mais cela fonctionne si j'enlève simplement cette ligne de code … c'est juste de le faire sur toutes les pages qui est très contraignant.

    Je vient de tester avec rapidweaver, et les pages générées comportent également cette ligne ...

    Mal barré tout ça, non ?

    :?



  • écrit tes pages à la main :roll:


  • Administrateur

    Y a pas une option pour lui indiquer de ne pas rajouter le type xml en début de page ?
    Autrement, sur mac, j'avoue que les choix sont limités en éditeur web…



  • @caaptusss:

    Y a pas une option pour lui indiquer de ne pas rajouter le type xml en début de page ?
    Autrement, sur mac, j'avoue que les choix sont limités en éditeur web…

    En même temps, pour le web, tu prend coda ou dreamweaver c'est les seuls éditeurs qui valent quelque chose (payant par contre :/)
    En ce qui me concerne j'utilise Coda qui est très bien :)

    (donc si jamais tu le cherches freelance, dis le moi ;) )



  • @Althalus:

    écrit tes pages à la main :roll:

    Tu es gentil.

    @caaptusss:

    Y a pas une option pour lui indiquer de ne pas rajouter le type xml en début de page ?
    Autrement, sur mac, j'avoue que les choix sont limités en éditeur web…

    Non, je ne crois pas que cela soit possible avec iWeb …

    @Althalus:

    En même temps, pour le web, tu prend coda ou dreamweaver c'est les seuls éditeurs qui valent quelque chose (payant par contre :/)
    En ce qui me concerne j'utilise Coda qui est très bien :)

    (donc si jamais tu le cherches freelance, dis le moi ;) )

    Merci, mais vraiment, je ne me sent pas d'écrire mon site à la main … pas les compéteces, ni le temps ...
    Mais c'est vrai que Coda à l'air très bien !

    Bien bien bien, nous voila bien avancés ...
    Help !


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.