Problème joomla+sef



  • bonjour:
    j'ai fait une recherche sur le forum et j'ai exactement le même problème que cette utilisateur http://www.freeheberg.com/phpbb2/viewtopic.php?t=1531&highlight=joomla+sef

    c'est à dire je cherche que mes urls soit de la forme
    http://greenlabo.fr/photos-animaux

    au lieu de
    http://greenlabo.fr/index.php?option=co … 1&Itemid=2

    donc j'ai suivi un tuutoriaux qui explique de renomer le fichier "htaccess.txt" à la base du site en .htaccess et ensuite j'ai activé dans mon menu joomla
    Search Engine Friendly URLs "yes"
    Use Apache mod_rewrite "no"
    Add suffix to URLs "yes"

    et donc cela ne marche pas, erreur 404, je vous montre mon fichier .htaccess, en éspérant que vous trouviez une soluce je vous remercie pour votre futur réponse

    ##
    # @version $Id: htaccess.txt 9975 2008-01-30 17:02:11Z ircmaxell $
    # @package Joomla
    # @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Joomla! is Free Software
    ##
    
    #####################################################
    #  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
    #
    # The line just below this section: 'Options +FollowSymLinks' may cause problems
    # with some server configurations.  It is required for use of mod_rewrite, but may already
    # be set by your server administrator in a way that dissallows changing it in
    # your .htaccess file.  If using it causes your server to error out, comment it out (add # to
    # beginning of line), reload your site in your browser and test your sef url's.  If they work,
    # it has been set by your server administrator and you do not need it set here.
    #
    #####################################################
    
    ##  Can be commented out if causes errors, see notes above.
    Options +FollowSymLinks
    
    #
    #  mod_rewrite in use
    
    RewriteEngine On
    
    #  Uncomment following line if your webserver's URL
    #  is not directly related to physical file paths.
    #  Update Your Joomla! Directory (just / for root)
    
    # RewriteBase /wordpress/
    
    ########## Begin - Joomla! core SEF Section
    #
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !^/index.php
    RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$  [NC]
    RewriteRule (.*) index.php
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
    #
    ########## End - Joomla! core SEF Section
    
    ########## Begin - Rewrite rules to block out some common exploits
    ## If you experience problems on your site block out the operations listed below
    ## This attempts to block the most common type of exploit `attempts` to Joomla!
    #
    # Block out any script trying to set a mosConfig value through the URL
    RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
    # Block out any script trying to base64_encode crap to send via URL
    RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
    # Block out any script that includes a <script> tag in URL
    RewriteCond %{QUERY_STRING} (<|%3C).*script.*(>|%3E) [NC,OR]
    # Block out any script trying to set a PHP GLOBALS variable via URL
    RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
    # Block out any script trying to modify a _REQUEST variable via URL
    RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
    # Send all blocked request to homepage with 403 Forbidden error!
    RewriteRule ^(.*)$ index.php [F,L]
    #
    ########## End - Rewrite rules to block out some common exploits
    
    

  • Administrateur

    Il y a des modifications à faire dans le .htaccess de joomla qui ne fonctionne pas dans sa configuration par défaut.

    Te dire quelles modifications, je ne sais pas. Il faut chercher sur le forum ou sur des sites spécialisés.



  • utilise le module : Sh404SEF et dans la confi de ce module choisi : indexphp? (le ? est important sinon ça marche pas)
    Ne pas toucher au htaccess ni autre réglage.


Log in to reply