Connexion à mysql HELP !!! Acces denied…



  • Bonjour, ca fait quelques heures que je tourne en rond à vérifier et revérifier mon erreur mais je n'ai rien trouvé…

    J'ai un site qui tourne en local sur wamp depuis pas mal de temps... rien à dire, je sais comment me connecter.

    Mon problème est donc quand je veux le mettre en ligne.

    J'ai corrigé la connexion à mysql :

    mysql_connect("localhost","login","mot de passe");
    mysql_select_db("ma base");

    Mais j'obtiens toujour ces erreurs :
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'titia'@'localhost' (using password: YES)
    Warning: mysql_select_db() [function.mysql-select-db]: Access denied for user 'titia'@'localhost' (using password: NO)

    Après avoir lu et relu le mail d'activation de ma base de j'appercois qu'il y a deux mots de passes => un pour l'identifiant "password" (une série d'une 30ene de caractères)
    et un pour la base (une série d'une 10ene de caractères).

    Les deux sont - ils à renseigner ???
    Y a t-il d'autres manip à faire ?? J'arrive à me connecter sur phpmyadmin sans soucis…

    Merci de venir à mon aide !! Je précise que je ne suis pas forcément très expérimenté en la matière...

    Laetitia.



  • Bonjour,

    Je vais te faire un exemple :

    mysql_connect("localhost","titia","mot de passe");
    mysql_select_db("titia");

    Bon alors :

    • Login et base sont les mêmes
    • Et le mot de pass c'est celui qui fais 10 caractères environs …

    Corentin



  • Je te remercie pour ta réponse.

    Je viens d'essayer, ca ne marche toujours pas….

    Pour expliquer ce que j'ai fait,

    Dans mon espace administrateur, j'ai crée une nouvelle base titia_mabase. J'ai donc importé ma base à cet endroit.

    Mais si mon login est "titia" et ma base est "titia_mabase", je ne peux pas avoir la même chose pour login et base...

    Deplus pour le serveur, dois-je mettre
    =>"localhost" (le nom du serveur que j'ai eu à mon inscription? )
    OU
    => "NS10" (le serveur qu'il y a marqué a coté du récap de mes bases sur mon compte admin)?

    Enfin, j'ai essayé les deux rien ne marche....



  • essaye sa :

    mysql_connect("localhost","titia","mot de passe");
    mysql_select_db("titia_mabase");



  • Non, ca marche toujours pas…

    De quoi m'arracher les cheveux lol

    Je comprend pas...

    "localhost" c'est vraiment le serveur de firstheberg??? Et pourquoi un autre code pour le serveur de ma base de donné? Ya un mix a faire pour obtenir le réel serveur???

    Tu as un site en ligne avec firstheberg et tout marche parfaitement ???



  • EDIT



  • C'est bon j'ai trouvé !! Ca marche… enfin !! Jte remercie... En fait je ne m'étais pas faite à filezilla que je viens de découvrir et il ne me mettait pas à jour mes fichiers...

    En tout cas, merci à toi !!!



  • ^^ Dac :D :D

    Corentin


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.