Petit probleme de debutant



  • bonjours a tous
    voila j'expose mon problème
    j'ai créer un site avec dreamweaver
    donc maintenant que mon site et fini j'ai un dossier ''site web'' qui contient mon index et un dossier design (c'est comme sa que je l'ai nommé) dans le dossier design il y a plusieurs dossier avec mes images et mes pages web et d'autre choses utiles a mon site

    quand je regarde mon site dans mon navigateur (sans le publier) tous fonctionne bien
    j'ai entrer toute les info nécessaire a la connexion
    jusque la tous va bien la connexion se fait sans problème
    je transfert donc mes 2 fichiers sur le serveur dans le sous dossier www
    tous le transfert se fait correctement tous les transfert réussi donc nickel
    et non c'est la que sa coince :blues
    maintenant je vais sur le site et la magie c'est OK
    par contre dés que je veut aller sur une autre pages toute les images disparaisse et le menu n'apparait plus correctement
    es ce que je fait une mauvaise manipulation ou es ce qu'il faut ranger les pages dans un autre dossier
    je vous met l'adresse comme sa vous pourrez mieux comprendre ce que je dis
    http://europas.freeheberg.com/
    d'avance merci a tous
    ludo



  • En fait, c'est simple (fin, j'ai pas chercher en profondeur, donc c'est pas certains, mais à priori, j'ai rien vu d'autre)
    Dans ton index, tu te situe dans le "root" (à la racine) de ton site, donc tes images qui sont dans ./design/ sont accessible via le chemin "design/tonimage…."
    Par contre, tes liens pointent vers des pages qui sont dans "./design/pages/" (exemple: http://ns14.freeheberg.com/~europas/des … elles.html ) du coup, si tu veux récup les images, tu dois adapter le chemin de tes images (le chemin ne sera plus "design/image.png" mais "../image.png")

    Voilà pour l'exemple.

    Pour des sites en html pure (sans php, donc pas dynamique), tu aurais meilleure temps de mettre toutes tes pages au même niveau (à la racine en gros) ce sera plus simple pour toi.

    Par contre, pour une facilitée de gestion des contenue récurent (les entêtes, menus etc) je te conseillerai de te mettre au PHP (avec des includes), mais bon, c'est peut-être pas encore dans tes projets immédiat, je ne sais pas :)

    Bon courage en tout cas.



  • L'url de ton css et de tes images sont sous cette forme : file:///C|/Users/ludovic lemoing/Desktop/essaie/design/style.css
    Autrement dis, il faut modifier l'url des images vue que le site n'est pu sur ton pc



  • @Game-War:

    L'url de ton css et de tes images sont sous cette forme : file:///C|/Users/ludovic lemoing/Desktop/essaie/design/style.css
    Autrement dis, il faut modifier l'url des images vue que le site n'est pu sur ton pc

    A bah, j'avais vu faux, même si dans l'idée c'était surement pas très faux non plus :D (j'ai pas chercher plus en profondeur que ça ^^)

    En gros, problème de liens absolu...



  • si je comprend bien il faut que a la place d'avoir sa
    <div align="center"><img src="design/banniere (2).png" alt="" width="1193" height="98" /></div>
    je dois mettre sa
    <div align="center"><img src="www/design/banniere (2).png" alt="" width="1193" height="98" /></div>

    c'est sa ou pas parceque je suis vraiment pommé
    je travail avec dreamweaver
    donc c'est compliqué

    help me

    j'ai chercher sur le net mais je n'ai pas trouver



  • @europas:

    <div align="center"><img src="design/banniere (2).png" alt="" width="1193" height="98" /></div>

    Ca c'est ce que tu met si tu es dans "www" (donc à la racine de ton site)

    Tes pages sont pour les 3/4 dans "design/pages", donc c'est plus

    <img src="design/banniere (2).png" alt="" width="1193" height="98" />
    ```mais
    

    <img src="../banniere (2).png" alt="" width="1193" height="98" />

    Tu dois mettre tes liens toujours par rapport à là où tu place tes fichiers

  • Administrateur

    Je lui ai fait un cours complet sur le support. Si ça ne lui suffit plus, je me tire une balle.



  • mdr merci mais ne t'en fais pas tu ma bien aidé :biglol mon site est operationnel et je te remercie pour toute ton aide
    encore une fois merci beaucoup


Log in to reply