Problème ftp (vsftpd)



  • Bonjour,
    Quand je me connecte sur mon ftp vsftpd avec filezilla et que je télécharge ou envoie des données j'ai des timed out entre chaque fichier télécharger sur le prochain fichier a télécharger et ainsi de suite, comme ceci :

    Statut :	Connexion à 91.229.20.82:21...
    Statut :	Connexion établie, attente du message d'accueil...
    Réponse :	220 (vsFTPd 2.3.2)
    Commande :	USER citron246
    Réponse :	331 Please specify the password.
    Commande :	PASS ****
    Réponse :	230 Login successful.
    Commande :	OPTS UTF8 ON
    Réponse :	200 Always in UTF8 mode.
    Statut :	Connecté
    Statut :	Démarrage du téléchargement de /cron.php
    Commande :	CWD /
    Réponse :	250 Directory successfully changed.
    Commande :	TYPE A
    Réponse :	200 Switching to ASCII mode.
    Commande :	PASV
    Réponse :	27 Entering Passive Mode (91,229,20,82,137,167).
    Commande :	RETR cron.php
    Réponse :	150 Opening BINARY mode data connection for cron.php (4450 bytes).
    Réponse :	226 Transfer complete.
    Statut :	Transfert de fichier réussi, 4 450 octets transférés en 1 seconde
    Statut :	Démarrage du téléchargement de /GPL.txt
    Commande :	PASV
    Erreur :	Délai d'attente expiré
    Erreur :	Echec du transfert du fichier
    Statut :	Connexion à 91.229.20.82:21...
    Statut :	Connexion établie, attente du message d'accueil...
    Réponse :	220 (vsFTPd 2.3.2)
    Commande :	USER citron246
    Réponse :	331 Please specify the password.
    Commande :	PASS ****
    Réponse :	230 Login successful.
    Commande :	OPTS UTF8 ON
    Réponse :	200 Always in UTF8 mode.
    Statut :	Connecté
    Statut :	Démarrage du téléchargement de /GPL.txt
    Commande :	CWD /
    Réponse :	250 Directory successfully changed.
    Commande :	TYPE A
    Réponse :	200 Switching to ASCII mode.
    Commande :	PASV
    Réponse :	27 Entering Passive Mode (91,229,20,82,110,233).
    Commande :	RETR GPL.txt
    Réponse :	150 Opening BINARY mode data connection for GPL.txt (32422 bytes).
    Réponse :	226 Transfer complete.
    Statut :	Transfert de fichier réussi, 32 422 octets transférés en 1 seconde
    Statut :	Démarrage du téléchargement de /index.php
    
    ```Je tiens a préciser un important temps de latence a la commande PASV 1 fois sur 2 même pour lister des fichiers
    J'ai essayer plein de tutoriel mais aucun n'a résolue mon problème.
    ma config vsftpd :
    

    #Le serveur n'écoute pas en continue.
    listen=NO
    #Pas de connections anonymes.
    anonymous_enable=NO
    #Connections des logins locaux acceptées
    local_enable=YES
    #Les users hors système possèdent les mêmes privilèges que les locaux
    virtual_use_local_privs=YES
    #On autorise les manipulations de fichiers via ftp. Au choix.
    write_enable=YES
    #On autorise les connections sur le port 20.
    connect_from_port_20=YES
    #Nom du service déclaré dans la configuration Pam.
    pam_service_name=vsftpd
    #On autorise les connections invitées afin de les "convertir" vers une nouvelle identité.
    guest_enable=YES
    #Puisque c'est pour manipuler du contenu web, www-data et l identité qui convient.
    guest_username=www-data
    #Permet de créer des répertoires personnels à la volée en fonction du contenu de guest_username.
    #Si l utilisateur est www-data, son répertoire devrait être /var/www/homes/$USER.
    #Ainsi chaque guest aura son répertoire perso dans /var/www/ .
    user_sub_token=$USER
    #Sera la racine du serveur ftp
    local_root=/var/www/$user
    #On emprisonne les processus utilisateurs
    chroot_local_user=YES
    #Cette option permet d'afficher TOUS les fichiers sous l identité ftp:ftp.
    #Permet également de masquer le nom du serveur.
    hide_ids=YES
    #On conserve une trace de toute connections ou tentative.
    xferlog_enable=YES
    #On détermine ou seront les fichier de configuration de chaque utilisateur virtuel.
    user_config_dir=/etc/vsftpd/vsftpd_user_conf

    pasv_enable=YES
    pasv_min_port=1024
    pasv_max_port=60000

    config pam :
    

    auth required pam_pwdfile.so pwdfile=/etc/vsftpd.passwd
    account required pam_permit.so

    anon_world_readable_only=NO
    local_root=/var/www/html
    write_enable=YES
    anon_upload_enable=YES
    anon_mkdir_write_enable=YES
    anon_other_write_enable=YES

    config xinetd :
    

    Conditions pour le réveil du ftp

    service ftp
    {
    disable = no
    socket_type = stream
    wait = no
    user = root
    server = /usr/sbin/vsftpd
    per_source = 5
    instances = 200
    only_from = 82.246.20.43
    banner_fail = /etc/vsftpd.busy_banner
    log_on_success += PID HOST DURATION
    log_on_failure += HOST
    }


  • Administrateur

    Joue avec le mode actif / passif. On avait le même soucis en interne, il est réglé depuis.



  • le réglage en mode passif donne les même résultat.
    quand a l'actif ca reste bloqué sur la commande LIST :

    éponse :	220 (vsFTPd 2.3.2)
    Commande :	USER citron246
    Réponse :	331 Please specify the password.
    Commande :	PASS ****
    Réponse :	230 Login successful.
    Commande :	OPTS UTF8 ON
    Réponse :	200 Always in UTF8 mode.
    Statut :	Connecté
    Statut :	Récupération du contenu du dossier...
    Commande :	PWD
    Réponse :	257 "/"
    Commande :	TYPE I
    Réponse :	200 Switching to Binary mode.
    Commande :	PORT 192,168,0,5,199,91
    Réponse :	200 PORT command successful. Consider using PASV.
    Commande :	LIST
    Erreur :	Délai d'attente expiré
    Erreur :	Impossible de récupérer le contenu du dossier
    


  • jai trouvé ! falai que jouvre en –sport sur iptables pour l'actif
    merci bien


Log in to reply