Demande quelques infos sur VPS



  • Bonjour,

    Je voudrais héberger un blog wordpress (avec 12 plugins) sur un petit VPS. Je suis actuellement sur un mutualisé d'un autre fournisseur, mais le chargement SQL est un peu lent par moment et mon thème est un peu lourd car j'ai une image de fond de 300ko et une font TTF 25ko. J'ai déjà utilisé un dédié atom pour un autre site, et après c'est difficile de revenir sur du mutualisé.
    Je souhaiterais utilisé debian serveur, la dernière version stable. (6.0.4 donc). Je voudrais utiliser, SSH, phpmyadmin, php, sql, la réécriture d'URL et la compression Gzip pour mes pages web. Iredmail pour la messagerie.
    J'ai déjà un nom de domaine, je pourrais utiliser les DNS de firstheberg? Car je ne sais pas utiliser Bind sous linux pour créer mon propre serveur DNS.

    Le petit VPS à 5€ HT suffirait? J'ai 10 visiteurs uniques par jour et je pense en avoir entre 100 et 500 maxi la première année. Ce sont surtout des botnets qui visitent mon blog en ce moment. Il est encore en construction et je n'ai pas faut de publicité.

    On peut payer le VPS à 5€ HT par SMS? Ca reviendrait à combien d'euros de SMS par mois?

    Merci de m'avoir lu.


  • Administrateur

    Oui, ça peut convenir pour démarrer, tu pourras le faire évoluer selon tes besoins.
    Paiement par SMS possible via Allopass, mais ça va te couter une fortune. 1 Code = 1 Euro chez nous, mais tu payera 2.30 € par code…



  • Ok merci.
    Par contre s'est marqué stockage illimité. Mais pour créer une partition il faut bien une limite.
    1 coeur virtuel fait combien de GHz?



  • Il faut plutôt partir sur la base des 2vcore. Ils sont à peu près égaux à un core de Xeon, cadencé à 2.20 si mes souvenirs sont bons.

    Si les autres ne tirent pas dessus, c'est un core dédié que tu as.

    Niveau stockage, tu as une partition de 20Go au début. Upgrade "illimité" ensuite.

    Voilà ;)



  • Le premier VPS suffiras l'argement, tu as pas besoin de beaucoup de puissance pour 10 visiteur/Jour



  • Le premier VPS suffiras l'argement, tu as pas besoin de beaucoup de puissance pour 10 visiteur/Jour

    Je pense monter à 100 rapidement, car pour le moment je n'ai pas fait de pub, ni montré l'url à mon asso.

    Via un panel est ce que je peux réinstaller Debian quand je veux ou je dois faire appelle au support?


  • Administrateur

    Oui, la réinstallation est automatisé sur les VPS.
    Tu pourra monter en puissance au fur et à mesure de tes besoins via l'espace client également (facturation au prorata de la différence).



  • Le VPS n'est pas en français par défaut, j'ai donc tapé:
    dpkg-reconfigure locales


    Vous conseillez euro, ufo ou iso comme norme?

    Ensuite je tape locale, mais s'est toujours du POSIX.
    locale

    LANG=
    LANGUAGE=
    LC_CTYPE="POSIX"
    LC_NUMERIC="POSIX"
    LC_TIME="POSIX"
    LC_COLLATE="POSIX"
    LC_MONETARY="POSIX"
    LC_MESSAGES="POSIX"
    LC_PAPER="POSIX"
    LC_NAME="POSIX"
    LC_ADDRESS="POSIX"
    LC_TELEPHONE="POSIX"
    LC_MEASUREMENT="POSIX"
    LC_IDENTIFICATION="POSIX"
    LC_ALL=



  • Mieux vaut prendre l'utf-8 (comme conseillé d'ailleurs). Après tout dépends de tes besoins.

    Maintenant, j'ai aussi eu le soucis sur mon VPS au début, j'avais édité le fichier /etc/locale.gen, pour ne laisser que fr_FR.UTF-8 de décommenté, et lancé la commande locale-gen (le tout en root).



  • Resolu, il fallait redémarrer le service pour que le changement soit pris en compte.



  • Sinon on peut utiliser le serveur DNS de firsrheberg pour pointer mon NDD sur le VPS?
    Ou il vaut mieux utiliser le registrar? (internetbs)


  • Administrateur

    Utilise ton registar pour le moment. On ne fournit pas encore de serveurs DNS (ça va venir).



  • Ok j'ai rajouté un record A chez le registrar et c'est OK.

    J'ai un soucis pour la migration de mon wordpress. Le site ne fonctionne pas mais j'ai accès à l'administration.
    J'ai uploadé en SSH avec root.

    Réponse que j'ai eu sur la communauté WP.

    Si le répertoire est bien en 755, ce n'est pas le "CHMOD" qui est en cause mais le "CHOWN". Le problème risque de se présenter également pour les mises à jour. Essaye de mettre l'utilisateur Apache en propriétaire.

    Et avec une nouvelle installation de wordpress, le site fonctionne.


  • Administrateur

    Tu as une erreur quelque part ? Tu as lu les logs Apache ?
    Si tu fait un :
    ls -al ./* -R
    Ca donne quoi ? Tu vois le même User et Group partout ?



  • Je vois 2 root par ligne partout

    -rw-r--r-- 1 root root   105 12 avril 17:46 mysql_init.sql
    -rw-r--r-- 1 root root  1584 12 avril 17:46 mysql_vmail.sql
    -rw-r--r-- 1 root root  8819  8 janv. 16:44 openldap
    -rw-r--r-- 1 root root  2022  8 janv. 16:44 phpldapadmin
    
    

    sinon aussi erreur en HTTP et je n'ai pas été voir les logs. Quelqu'un se rappelle de la commande?


  • Administrateur

    Tu ne fait pas ton Ls dans le bon de dossier.
    Il faut te positionner dans le dossier qui contient le site pour faire la vérification.
    Pour lire les logs, il faut aller dans /var/log/ (ou /logs selon les distrib). Tu aura probablement les logs apache.



  • Que du root et quelques www-data www-data

    ./wp-includes/Text/Diff/Engine:
    total 48
    drwxr-xr-x 2 root root  4096 13 avril 14:24 .
    drwxr-xr-x 4 root root  4096 13 avril 14:24 ..
    -rw-r--r-- 1 root root 15844 13 avril 14:24 native.php
    -rw-r--r-- 1 root root  5170 13 avril 14:24 shell.php
    -rw-r--r-- 1 root root  8362 13 avril 14:24 string.php
    -rw-r--r-- 1 root root  2213 13 avril 14:24 xdiff.php
    
    ./wp-includes/Text/Diff/Renderer:
    total 16
    drwxr-xr-x 2 root root 4096 13 avril 14:24 .
    drwxr-xr-x 4 root root 4096 13 avril 14:24 ..
    -rw-r--r-- 1 root root 5535 13 avril 14:24 inline.php
    
    ./wp-includes/theme-compat:
    total 32
    drwxr-xr-x 2 root     root     4096 13 avril 14:22 .
    drwxr-xr-x 8 www-data www-data 4096 13 avril 14:22 ..
    -rw-r--r-- 1 root     root     4013 13 avril 14:22 comments.php
    -rw-r--r-- 1 root     root     5233 13 avril 14:22 comments-popup.php
    -rw-r--r-- 1 root     root     1219 13 avril 14:22 footer.php
    -rw-r--r-- 1 root     root     1724 13 avril 14:22 header.php
    -rw-r--r-- 1 root     root     3905 13 avril 14:22 sidebar.php
    

    Sinon j'ai été voir le fichier error.log et access.log dans le dossier apache2, il n'y a rien de spécial. Et quand je vais sur mon site, ca ne rajoute pas d'erreur.

    Ca pourrait venir du FTP? Car personne n'a accès au FTP et le port 20 et 21 sont fermés.
    Pourtant j'ai d'autre CMS qui fonctionne. Et quand je met l'url de image de wordpress, je les vois.



  • ce qui m'interesserait, au vu de ton problème c'est d'avoir la trace complète d'un "ls -aFlR" de ton répertoire /var/www (ou autre répertoire, selon ce que tu as défini comme racine de tes pages web).

    Car ça pu effectivement le problème de CHMOD/CHOWN.

    Peux-tu également tester de te connecter sur la page qui pose problème, et ensuite nous transmettre les dernières lignes du access.log et error.log apache (qui concerne ta tentative de connexion) ?

    Car au vu des traces que tu donnes c'est "impossible" de t'aider…

    (j'ai bien envie de te dire, fait un "chmod -R www-data:www-data /var/www" et "chmod -R 755" de la même chose... mais c'est un peu bourrin ^^)



  • j'ai testé ma sauvegarde sur un mutu gratuit, et il y avait une erreur php sur les pages à cause du script crawltrack, je l'ai supprimé et ca fonctionne. J'ai fait la même chose pour le VPS et ca fonctionne. L'erreur PHP ne s'affiche pas dans les logs d'apache2. Il doit y avoir une option pour afficher les erreurs PHP sur le navigateur et dans le log.

    Dernier soucis, autoriser le FTP à root, pour que WP puissent faire les mises à jour.


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.