Pertes de paquets



  • Bonsoir,
    J’héberge actuellement des serveurs de jeux sur des dédiés et VPS chez vous (et chez la concurrence) et je constate des pertes de paquets aussi bien sur le vps que sur le dédié (serveur atom).
    On peut le voir en faisant tourner différents tests (pas professionnels non plus :P ) :
    Ping : http://91.236.239.16/ping.png
    Lagometer (pour ceux qui connaissent, le carré en bas a droite) : http://91.236.239.16/lagometer.jpg
    pingtest.com : http://91.236.239.16/pingtest.jpg
    Je voulais savoir si c’était un problème lié à la configuration ou bien s'il y avait quelque chose à faire.
    Toute aide est la bienvenue !

    Merci d'avance et bonne soirée.


  • Administrateur

    Bonjour,

    Notre fibre optique est saturé (en rapport à l'incident indiqué ici : http://www.firstheberg.com/maintenance.php?detail=49 ). De ce fait, nous avions sur notre ancien routeur une règle qui consistait à augmenter la latence à environs 250 ms pour faire passer sur des débits corrects, mais ça ne convient pas à des activités de jeux en ligne.

    De ce fait, suite à la mise en place de notre nouveau routeur mercredi, nous avons changé la configuration. Désormais, la latence reste stable, et nous priorisons certains type de packets et certains protocoles.
    Par ordre de priorité (port y compris) :

    1. TCP (80, 22, 21, 443, etc...)
    2. UDP (53, etc...)
    3. ICMP

    De ce fait, le routeur va dropper des packets ICMP et UDP pour permettre à tout le monde de passer sans casse, et sur des latences correctes.
    C'est une solution qui à ce jour permet de continuer à avoir une bonne qualité de service sur les jeux vidéos (minecraft semble bien fonctionner avec ça, CS également).

    Cette solution est temporaire. D'ici quelques semaines (on espère avant fin juin), Completel aura réalisé une upgrade de notre fibre optique afin de nous permettre d'avoir un réseau dimensionné avec notre trafic.

    En espérant avoir été complet à ce sujet.



  • Tu peut refaire un test avec un ping et me donné le résultat ? Tu ne doit plus avoir de perte normalement.
    Pour ton jeux, les perte tu les vois seulement sur ton lagometer ou tu a des lag qui te perturbe ?



  • Alors tout d'abord merci à vous 2 pour les réponses rapides :)
    Donc caaptusss si j'ai tout compris mon serveur de jeu qui fonctionne en UDP (je suppose) est pas prioritaire sur le réseau et donc certains packets sont droppés? Merci pour ce post complet et bien expliqué au passage !
    Gilum, j'ai refait un ping et sur 95 requêtes tout arrive a destination ! Pour le lagometer, ca se ressent pas dans le jeu, sauf vraiment quand y'a plusieurs packets perdus à la suite. Dans tous les cas c'est pas très génant, je voulais juste connaître la raison :)



  • Si tu peut refaire un petit test demain entre 18h et 22h, l'heure de pointe quoi !



  • Je viens de refaire le test (19h47), et sur 157 paquets, tout arrive a destination :)
    Juste par curiosité, tu fais parti du service technique et tu as fait quelque chose ou bien?


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.