Installation Libraire GD



  • Bonsoir,

    Voilà je souhaite installer la librairie GD j'ai donc utilisé cette commande via putty apt-get install php5-gd
    j'ai redémarrer apache mais rien ne s'affiche dans le php info http://91.229.20.243/phpinfo.php

    Qu'est ce que je en fais pas ?
    Je précise qu'openpanel est installé sur mon serveur.

    Merci



  • redémarre php s'il est en mode fast-cgi et autre cgi-like car GD est porté par php et non par le serveur d'application. (j'ai plus la source de ce que je te dis là… mais je suis tombé sur un même genre de pb avec une autre lib utilisée par php)

    Sinon tente de redémarrer le serveur complet.



  • c'est ce que j'ai fait mais rien n'y fait .. je désespère…..



  • Pense a l' activer dans php.ini tu trouvera dans ce fichier :

    ;extension=gd.so enleve le point virgule puis redemarre apache

    en toutes logique avec cette commande**/etc/init.d/apache2 restart**



  • En fait mon probleme est là je en trouve pas le php ini lol.. j'utilise openpanel et je en le trouve nulle part…..



  • En passant via ssh

    etc/php/php.ini ou etc/php5/php.ini ou etc/php5/apache2/php.ini

    Puis redémarre apache /etc/init.d/apache2 restart



  • impeccable je l'ai trouvé lol : etc/php5/apache2/php.ini
    Merci ! je te tiens au courant… !



  • Alors j'ai trouvé ça dans php.ini [gd]
    ; Tell the jpeg decode to ignore warnings and try to create
    ; a gd image. The warning will then be displayed as notices
    ; disabled by default
    ; http://php.net/gd.jpeg-ignore-warning
    ;gd.jpeg_ignore_warning = 0

    est-ce que je dois rajouter la ligne ?



  • Oui mais vérifie que l orque tu as installé php-gd

    la librairie se soit bien installé



  • N oublie pas de redémarrer Apache

    Et tient nous au jus !! :wink:



  • Bon et bien je n'arrive plus à redémarrer apache.. je en sais plus quelle commande j'avais fait la dernière fois mais ça avait parfaitement fonctionné..
    Là ça me met cela :
    root@vps044:~# /etc/init.d/apache2 restart
    Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    … waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

    Je crois qu(il a décidé de me contrarier monsieur Apache :(



  • Bonjour
    Réponse très tardive mais on ne sais jamais.

    Dans ton fichier apache2.conf (en tout cas pour ma config à moi sous debian), tu rajoutes à la fin de ce fichier la ligne suivante:

    ServerName 127.0.1.1

    c'est tout.


Log in to reply