Une petite question sur la bande passante



  • Bonjour,

    je suis client FH depuis le début Janvier, avant j'étais auto-héberger à la maison derrière une box(freebox v4).
    J'ai Google analytycs et je suis surpris sur le temps de chargement d'une page, une image vaut mieux qu'un long discours:

    Ce qui est entouré en rouge est le passage chez FH.
    L'image parle d'elle même :?

    Merci de m'éclaircir.


  • Administrateur

    Qui est tu ? Qu'héberges tu chez nous ? Sur quel produit ? Avec quel site ?
    Je suis désolé d'avoir perdu ma boule de cristal :)



  • Bonjour caaptusss,

    comme indiquer, j'ai mis mon numéro de dossier dans mon profile, donc pas besoin de boule de cristal :D

    Mon identifiant chez FH est fredd, je loue un dédié ATOM D525 HDD.
    Le dns est http://srv30.firstheberg.net qui pointe sur http://memo-linux.com.
    J'héberge donc un site web sous Debian 6 avec le CMS Wordpress.
    Serveur web: Nginx+php5-fpm+Varnish.
    Serveur bdd: MySql 5.5

    Tu souhaites plus d'infos?


  • Administrateur

    Non, c'est pas mal. A première vue, je dirais que ton serveur met plus de temps à compiler ta page pour la renvoyer au navigateur. Ta latence vient probablement de là (un ATOM étant très peu performant pour compiler en CPU).



  • ok… donc rien à voir avec la bande passante alors?

    je scrute le monitoring du serveur est aucun pique de charge CPU, le load average est souvent en dessous de 1.
    Il y a quand même un truc que je en comprends pas..
    Ok le CPU compile la page(php5-fpm) une fois mais après? la page est en cache(Varnish) en RAM donc plus d'accès CPU(compilation) et normalement ça doit déboiter sévère donc la latence devrait être amoindri?

    Sachant que j'avais un meilleur taux de téléchargement derrière une vielle box(d'apèrs les outils de google webmastering)... ok côté CPU c'était un AMD Phenom II X4 B95 avec 8Go de Ram mais la bande passante était bien pourrie...

    En tout cas merci pour la réponse. :D


  • Administrateur

    Il y a parfois des temps de compilation incompressible en l'état, surtout avec du WP. J'ai vécu ça avec un client qui s'est barré pensant que c'était notre réseau, il est parti chez OVH avec un serveur de la même gamme, et il a eu le même problème (gros lol quand je l'ai vu revenir).

    Le pourquoi ça peut prendre plus de temps maintenant ? C'est compliqué car beaucoup de facteurs. Tu est sur une machine différente, donc avec des librairies différentes (peut être plus vielles ou plus récente) qui peuvent donc fausser tes mesures.

    Dans tous les cas, on parle ici en micro ou mili seconde, ce n'est donc pas perceptible par l'homme, et uniquement par Google. Tant que tu est à 0.10 ms de compilation, tout va bien :) Cet outils est surtout destiné à identifié les fortes latences pouvant engendrer un handicap dans la navigation.



  • @fredd:

    Serveur web: Nginx+php5-fpm+Varnish.
    Serveur bdd: MySql 5.5

    J'ai le meme serveur que toi .. et pratiquement la meme "config" (Varnish / Nginx / php5-fpm)
    J'utilise MariaDB (à la place de MySQL mais c'est fork de MySQL mais un tout p'tit peu plus rapide) .. j'ai mi une p'tite couche de cache dessus
    Et J'ai aussi APC (avec une autre couche de cache)

    Je ne sais pas si ça peut t'aider .. mais au cas .. je te donne l'info.

    Dans Nginx tu as autorisé combien de :
    worker_processes ?
    worker_connections ?
    worker_rlimit_nofile ?

    Dans Php5-FPM, tu as quoi comme valeur pour :
    pm ?
    pm.max_children ?
    pm.start_servers ?
    pm.min_spare_servers ?
    pm.max_spare_servers ?

    Etc ..



  • Salut airv,

    voici ma conf pour nginx:
    worker_processes 4
    worker_connections 1024
    worker_rlimit_nofile: je n'ai pas cette option

    voici ma Php5-FPM:
    pm = dynamic
    pm.max_chiodren = 5
    pm.start_servers = 2
    pm.max_spare_servers = 1
    pm.max_spare_servers = 3
    pm.max_requests = 200
    request_terminate_timeout = 30s

    je suis preneur pour toutes améliorations :D



  • Ok .. déjà .. pour moi tu as une mauvaise config pour les worker_processes .. (les autres je regarderais ce soir)

    si tu fais la commande suivante :

    cat /proc/cpuinfo | grep processor | wc -l
    

    Tu vois quoi ? Normalement tu devrais voir : 2 (vu qu'on a les "mêmes" machines)

    En gros c'est le nombre de coeur/cpu. Donc il faudrait deja que tu remplaces la valeur 4 par 2 dans worker_processes (et redemarrer le Nginx apres la modif)

    Le processeur que tu as, c'est : ATOM D525 2 x 1.8 Ghz



  • et pourtant le résulat de la commande

    cat /proc/cpuinfo | grep processor | wc -l
    ```est bien 4 :?
    je l'avais déjà fait lors de la config de nginx.


  • @fredd:

    et pourtant le résulat de la commande

    cat /proc/cpuinfo | grep processor | wc -l
    ```est bien 4 :?
    je l'avais déjà fait lors de la config de nginx.
    

    Sauf erreur de ma part : l'atom D525 a 2 coeur, mais 4 thread en fait, d'où le fait que tu obtienne 4 et non 2, vu que tu vois les coeur logique de l'hyperthreading



  • oui c'est ça!
    alors je dois mettre 2 ou 4 alors?



  • Bah moi .. quand je fais la manip .. je ne vois que 2 .. et pas 4 ..

    Essai 2 (vu que tu avais 4) .. et tu compares si c'est plus rapide deja :)



  • En faite le site est rapide, les temps de chargement sont assez bon(tester avec gtmetrix), c'est juste cette augmentation de temps de chargement que l'outil Webmaster tool me montre qui me fait poser cette question de bande passante.

    Le serveur ronrone comme il se doit, je n'ai pas aucune monté du Load average, j'ai fais des tests de monté en charge avec Blitz.io et Varnish joue son rôle à merveille…
    En gros le site est réactif et le serveur tient le coup. 8)

    une mise à jour des mesures de google:


Log in to reply