Problème de grub sur ubuntu server 12.04 en raid 0



  • Bonjour à tous,

    L'ensemble est dans le titre.
    Nouveau client ici, j'ai installé un ubuntu server 12.04 et ait commencé a effectué les mises à jour. Cependant, je suis incapable de résoudre certains problèmes.

    update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic
    grep: /boot/config-3.2.0-29-generic: No such file or directory
    W: mdadm: the array /dev/md/3_0 with UUID a68824fc:e5bbc1f6:9d4deba6:47ca997f
    W: mdadm: is currently active, but it is not listed in mdadm.conf. if
    W: mdadm: it is needed for boot, then YOUR SYSTEM IS NOW UNBOOTABLE!
    W: mdadm: please inspect the output of /usr/share/mdadm/mkconf, compare
    W: mdadm: it to /etc/mdadm/mdadm.conf, and make the necessary changes.
    W: mdadm: the array /dev/md/1_0 with UUID 61e4a195:6826919b:9d4deba6:47ca997f
    W: mdadm: is currently active, but it is not listed in mdadm.conf. if
    W: mdadm: it is needed for boot, then YOUR SYSTEM IS NOW UNBOOTABLE!
    W: mdadm: please inspect the output of /usr/share/mdadm/mkconf, compare
    W: mdadm: it to /etc/mdadm/mdadm.conf, and make the necessary changes.

    J'ai effectué ce qui est demandé ci dessus, c'est à dire utiliser la commande /usr/share/mdadm/mkconf et utiliser le contenu ainsi généré pour remplacer le fichier de conf, mais au reboot… J'ai plus rien.
    J'ai tenté ceci plusieurs fois.

    J'ai donc décidé de le réinstaller.
    Dès la première connexion, je fais ça :

    Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.14-std-ipv6-64 x86_64)

    System information as of Mon Jul 1 23:29:17 CEST 2013

    System load: 0.04 Processes: 112
    Usage of /home: 1.5% of 1.79TB Users logged in: 0
    Memory usage: 0% IP address for eth0: 91.236.239.115
    Swap usage: 0%

    Graph this data and manage this system at https://landscape.canonical.com/

    0 packages can be updated.
    0 updates are security updates.

    Last login: Mon Jul 1 23:28:11 2013 from ---.hfc.dyn.abo.bbox.fr
    root@srv266:~# update-grub
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    Generating grub.cfg ...
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    Found linux image: /boot/bzImage-3.2.14-ipv6-64
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    error: found two disks with the index 0 for RAID md3.
    error: superfluous RAID member (2 found).
    done

    Il n'y aurait pas un problème dans l'installation ?



  • Je pense que cela est du à une mauvaise configuration du RAID ou/et à une mauvaise installation du RAID.
    Réinstalle la machine depuis l'espace client, en retirant le RAID au moment de la configuration de la réinstallation, et regarde si cela le fait toujours.



  • Oui, en effet, c'est bien un problème de RAID à priori, car sans, je n'ai aucun problème.
    Je rencontre le même problème on dirait avec un RAID 1. Bon, j'ai jamais utilisé de RAID auparavant, donc je suis un total noob à ce niveau.

    Mais c'est un peu dommage de ne pas activer le RAID et de perdre un disque dur.

    Cependant, avec une Debian, j'ai aucun soucis à utiliser le RAID 0. Mais je préférerais vraiment Ubuntu ^^"



  • Alors, ceci est un problème d'ISO. Bien dommage que le support soit très peu voir trop peu actif.



  • Donc… Pas d'Ubuntu 12.04 avec les 2 To en RAID 0 ?
    Puis-je espérer une résolution aujourd'hui ? Dois-je ouvrir un ticket ?


  • Administrateur

    Pas de support officiel sur le forum. C'est du temps libre de l'équipe.
    Si besoin, ouvrir un ticket.



  • Ca marche, j'ai ouvert un ticket, merci bien :)



  • @caaptusss:

    Pas de support officiel sur le forum. C'est du temps libre de l'équipe.
    Si besoin, ouvrir un ticket.

    J'ai déjà ouvert un ticket pour ma part, et même des emails, très peu sont répondus malheureusement.



  • J'ai cloturé le ticket, je n'ai pas reçu de réponse et j'ai réussi à mettre à jour le serveur sans le planter.

    Ma config est la suivante à la fin :

    root@srv266:/etc/mdadm# cat mdadm.conf

    mdadm.conf

    Please refer to mdadm.conf(5) for information about this file.

    by default (built-in), scan all partitions (/proc/partitions) and all

    containers for MD superblocks. alternatively, specify devices to scan, using

    wildcards if desired.

    #DEVICE partitions containers

    auto-create devices with Debian standard permissions

    CREATE owner=root group=disk mode=0660 auto=yes

    automatically tag new arrays as belonging to the local system

    HOMEHOST <system>

    instruct the monitoring daemon where to send mail alerts

    MAILADDR root

    definitions of existing MD arrays

    ARRAY /dev/md/0 metadata=1.2 UUID=f6b6e16d:471dae5a:17464e06:e8b89d10 name=srvtest:0
    ARRAY /dev/md/1 UUID=47ad57bf-4680-47cd-8701-3f57d200b35f
    ARRAY /dev/md/3 UUID=e3c4f691-15bb-40a5-8d18-f38d4cc9ca6a

    This file was auto-generated on Thu, 06 Dec 2012 19:01:33 +0100

    by mkconf $Id$

    md0 étant la config d'origine

    ARRAY /dev/md/0 metadata=1.2 UUID=f6b6e16d:471dae5a:17464e06:e8b89d10 name=srvtest:0

    Et md1 et md3 que j'ai obtenu avec la commande blkid

    ARRAY /dev/md/1 UUID=47ad57bf-4680-47cd-8701-3f57d200b35f
    ARRAY /dev/md/3 UUID=e3c4f691-15bb-40a5-8d18-f38d4cc9ca6a

    Commande blkid :

    root@srv266:/etc/mdadm# blkid
    /dev/sda1: UUID="590c1df3-18a2-392a-9d4d-eba647ca997f" TYPE="linux_raid_member"
    /dev/sda2: UUID="d1e41d51-be78-4161-b171-f85900c0edb5" TYPE="swap"
    /dev/sda3: UUID="ed546461-4dbb-76d5-9d4d-eba647ca997f" TYPE="linux_raid_member"
    /dev/sdb1: UUID="590c1df3-18a2-392a-9d4d-eba647ca997f" TYPE="linux_raid_member"
    /dev/sdb2: UUID="b1911d51-dd6e-47bf-8de6-afdafe7009cd" TYPE="swap"
    /dev/sdb3: UUID="ed546461-4dbb-76d5-9d4d-eba647ca997f" TYPE="linux_raid_member"
    /dev/md3: UUID="e3c4f691-15bb-40a5-8d18-f38d4cc9ca6a" TYPE="ext4"
    /dev/md1: UUID="47ad57bf-4680-47cd-8701-3f57d200b35f" TYPE="ext4"

    Bonne soirée


  • Administrateur

    Oui, je n'ai pas eu le temps d'analyser ton ticket. Tant mieux si tu as trouvé une solution.


Log in to reply