[Résolu] Souci réseau avec VM Proxmox



  • Bonjour à tous,
    voici mon souci :

    Je voudrais mettre le net sur ma VM (et non un CT) sous ProxMox. J'ai des Ips supplémentaire et c'est un Windows. Mon souci est que je ne sais pas comment faire. Coté CT j'ai un réseau NAT qui fonctionne bien.

    Dois-je créer vmbr1 en interface réseau si oui comment la configurer ? Dois-je plutôt assigner la nouvelle IP sur vmbr0 et comment faire pour l'assigner derrière à ma VM ?

    Je suis un peu perdu si quelque'un pouvait m'aider.

    Merci à tous !

    Edit: j'ai NAT avec une nouvelle interface



  • Salut, tu as réglé le problème depuis ?

    Je vais réinstaller en proxmox avec des ips supp, si sa marche je te transmet la manip, si jamais c'est régler tu peux donner la marche a suivre pour win ?

    Cordialement



  • Bonjour,

    j'ai ouvert un ticket mais pour le moment rien qui fonctionne, je te tiens au courant si de mon coté j'ai quelque chose.

    Voici la réponse du ticket :

    Bonjour,

    Je n'ai pas de tuto ou how to tout fait, mais c'est relativement simple.
    Vous avez plusieurs modes de routage que vous pouvez utiliser sur Proxmox.
    Vous pouvez faire un mode bridge, ou un mode routé.

    Le mode bridge s'active assez simplement dans proxmox, et permet à la VM de communiquer avec internet. La passerelle à appliquer dans ce cas sur la VM est l'ip de la machine hote.

    Le mode routé est sensiblement identique, à la différence qu'il faut insérer des règles iptables sur la machine hote. La config réseau est identique sur la VM que le mode bridge, à la différence que le fait de rajouter des routes permet au visiteur de connaitre l'ip de l'hyperviseur.

    Vous avez un tuto plutôt sympa chez OVH qui peut s'appliquer aussi chez nous :
    http://guides.ovh.com/Proxmox

    Cordialement,
    FirsHeberg.com

    J'ai répondu suite à cela :

    Merci pour votre réponse,

    quand je vais dans réseau sur le superviseur pour ajouter une interface je fais (pour bridge)

    Nom vmbr1
    IP : mon_ip_supplémentaire
    Mask : 255.255.255.0
    Gateway: l'ip de mon dédié
    bridge port: eth1

    et il me dit => gateway: Default gateway already exists on interface 'vmbr0'.

    –--
    Au niveau du guide que vous m'avez donné il dise ne pas aborder le bridge sur OpenVZ pour des questions de perfs.


  • Administrateur

    J'ai demandé en interne, je reviens vers toi prochainement.



  • Le lien d'ovh m'a l'air assez clair ! ça ne marche pas ?

    créer une vm routed
    tu indique l'ip failover (ip supplémentaire)
    puis sur la vm :

    auto lo eth0
    iface lo inet loopback
    iface eth0 inet static
        address IP.FAIL.OVER
        netmask 255.255.255.255
        broadcast IP.FAIL.OVER
        post-up route add IP.DE.VOTREDEDIE dev eth0
        post-up route add default gw IP.DE.VOTREDEDIE
        post-down route del IP.DE.VOTREDEDIE dev eth0
        post-down route del default gw IP.DE.VOTREDEDIE
    

    et sur du win sa doit être une config tcp/ip basique avec l'ip failover ?

    Par contre il faut peut être ajouter les routes ? j'ai du le faire en local



  • quand je vais dans réseau sur le superviseur pour ajouter une interface je fais (pour bridge)

    Nom vmbr1
    IP : mon_ip_supplémentaire
    Mask : 255.255.255.0
    Gateway: l'ip de mon dédié
    bridge port: eth1

    et il me dit => gateway: Default gateway already exists on interface 'vmbr0'.



  • Même erreur !

    Pour contourner pour l'instant j’édite le fichier de conf :

    /etc/network/interfaces


Log in to reply