Problème avec les IP supplémentaires



  • Je souhaiterai héberger 2 VM's avec 2 ip failover mais impossible d'avoir accès a Internet "Réseau Local" donc ping ne fonctionne pas en externe.

    _Dite moi ou et le problème s'il vous plait j'ai était recherchée sur pas mal de site mais je vois pas ou et mon erreur  :)
    _



  • Proxmox ?

    Peut-on avoir ta config réseaux de la machine hôte ?



  • Bonjour,

    As-tu résolu ton problème, car j'ai le même souci pour une VM sous windows 2012
    d'après mes recherche, cela vient de ma passerelle.
    Hors le support me dit qu'il faut mettre comme passerelle mon IP de mon serveur dédié
    Donc:
    Adresse IP:  89.xxx.xxx.xxx      - IP Failover commence bien par 89
    Masque    : 255.255.255.255
    Passerelle : 91.xxx.xxx.xxx      - IP de mon dédié  commence bien par 91

    Dès que je clique sur OK le message suivant apparait

    << Avertissement - La passerelle par défaut n'est pas sur le même segment réseau (sous-réseau) qui est défini par l'adresse IP et le mase de sous-réseau. Voulez-vous sauvegarder cette configuration ? >>

    ça veut bien dire ce que ça dit,  mon IP Failover n'est pas sur le même segment que l'IP du dédié



  • Es-tu bien sûr que comme passerelle, tu dois mettre l'ip de ton serveur dédié? C'est pas plutot l'ip de la passerelle (gateway, gw) de ton serveur dédié ?

    Dans tous les cas, tu seras aussi sur un réseau séparé et tu auras aussi le warning, il faut rajouter une route à la main vers la passerelle sur ton interface.
    Sur windows je sais pas comment vous faites, mais sous linux, c'est: route add ${IP_PASSWERELLE} dev eth1

    Dans mon cas: route add 91.236.254.1 dev eth1



  • Bonjour,

    Merci de pencher sur mon problème.

    "C'est pas plutôt l'IP de la passerelle (gateway, gw) de ton serveur dédié ?"
    C'est ce que j'ai fais au départ, puis le support me dit d'entré l'IP de mon dédié.
    Mais de toute façon, même message d'erreur :-[ .

    Windows dans VirtualBox était beaucoup plus simple, puis qu'il suffisait de dire que j'accède au réseau par pont et le tour est joué.
    mais apparemment windows 2012 refusera d'exécuter VirtualBox.

    En fait, il faudrait qu'un spécialiste en Hyper-V tombe sur ce poste.
    Mon but étant bien sur que les VMs est accés à internet.

    J'ai essayé de faire un pont avec Pfsense, IpCop, ZeroShell mais rien n'y fait. :'(



  • Ouvre l'invite de commande sous windows (exécuter -> "cmd"):

    tape :```
    ipconfig /all

    
    Prend l'IPv4 de ton serveur, le masque de sous réseau, la passerelle et le serveur DNS.
    Met ça dans la fenêtre windows correspondantes (cf. le screen premier post)
    
    Ensuite clique sur "Avancé" et là clique sur "Ajouter" dans la partie "Adresse IP" et ici tu rentre ta 2e IP et le même masque de sous réseau que tout à l'heure.


  • Déjà fais Althalus,
    Voila ce que j'avais fait, j'ai peut-être commis une erreur

    Dans mon dédié (Prévoir le KVM) désactiver le DHCP
    Dans ma fenêtre Windows correspondante faire ce que tu dis.
    PUIS  dans "Avancé"  "Ajouter"  "Adresse IP"
    89.x.x.x                Mon IP supplémentaire
    255.255.255.255  Masque

    Mais quand je ping depuis chez moi, l' IP supp n'est pas accessible



  • Je viens de comprendre quelque chose, les IP supplémentaires de chez firstheberg.com ne fonctionne pas comme un IP Failover.
    mais comme son nom l'indique (supplémentaire), donc lié au dédié et non utilisable dans une VM.



  • Bon et bien pour moi le sujet et clos ;D.
    Si le support ne m'avait pas laisser continuer dans mon erreur :(, j'aurais pu passer à autre chose.
    Donc pour ceux qui comme moi cherche toujours, la réponse d'Althalus est la bonne.
    J'avais pas poussé mon teste plus loin lorsque je ne pouvais pas pinguer l'adresse,
    mais l'IP est accessible même si je peux pas pinguer (pare-feu surement)

    MERCI en tout cas.



  • Ca vient soit de ton hôte le fait que tu ne puisse pas ping (ip forward selon le cas), soit du parefeu windows (ça me parait gros, mais pourquoi pas), soit test de redémarrer ta machine (pas seulement la VM)



  • En fait cela vient de mon pare-feu (Look 'n' Stop) pour le ping.
    Mais pour la VM, ce n'est pas résolu, je me suis fait une fixation sur l'IP supplémentaire.
    Maintenant je sais qu'il faut que je trouve le moyen de faire une route entre le dédié et les VMs pour qu'ils puissent avoir accès à l'internet.
    Je vais me pencher sur IPcop ou autre pour créer une route.  Toutes pistes sont les bienvenus.



  • Les ips supplémentaires de Firstheberg marche très bien sur des VM !



  • nyny1895, peux-tu me donner la marche à  suivre pour windows,

    Adresse IP: ip supplémentaire
    Masque    :
    Passerelle :

    Parce que j"y suis pas arrivé. mais je dois pas faire les choses correctement :-[ .

    Je précise que la VM est créé sous Hyper-V de windows.



  • Ah mince j'ai pas bosser sous hyper V

    Le seul indice que je peux te donner c'est que sous Proxmox tu doit créer une route (ip route add IP.FAIL.OVER dev CARTE-RESEAUX)

    Sous windows l'equivalent est :  route ADD 157.0.0.0 MASK 255.0.0.0  157.55.80.1 METRIC 3 IF 2
                                                                  destination^ masque^  passerelle^  métrique^Interface^

    tape route dans une cmd sinon tu aura plus d'info.

    En espérant que sa peut t'aider  :)



  • Merci nyny1895, j'y suis pas encore arrivé,
    mais je pense que la solution est là.
    merci encore.


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.