Your host needs to use PHP 5.3.1



  • Bonjour
    Mon soucis en installant joomla 3, message :
    Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!

    Comment résoudre ce soucis?
    Merci


  • Administrateur



  • ok et cela va fonctionné?



  • ok mais je le mets ou car 2 nom de domaine sur www?

    c fou qu'il n'y a pas de manip plus simple


  • Administrateur

    On va essayer d'imaginer un système pour que ça soit plus simple mais c'est relativement simple déjà ici, difficile de faire mieux :)



  • simple ben ca depend pour qui , mais pas pour moi :-(



  • en faite je ne comprend rien :-(



  • La jeunesse de nos jours..

    Créer un fichier htacces.txt, dans celui tu mets
    suPHP_ConfigPath /nas-1/tonnomdecompte/www/configphp/ (www/configphp/ = ou mettre le php.ini) (conseiller de pas le mettre dans le www mais qu'un détail à ton niveau)
    SetEnv PHP_VER 5

    ensuite, upload le sur ton ftp, et renomme le en .htacces dans le dossier /www (racine)
    (ne mets pas les éléments entre parenthèse dans ton htacces.txt)

    un lien de dwld au pire => http://www.mediafire.com/view/9bissr9wbstg39s/.htaccess
    édit le avec notepad pour mettre ton id compte, ou renomme le en txt.

    Et maintenant le php.ini  https://www.mediafire.com/?qc2dwaxdj6lu1de

    dezipp le et mets le dossier complet dans www. (sauf si tu modifies l'url d'accès dans ton htacces) conseil : le fais pas si tu n'as pas compris le tuto.

    Une fois ton htacces (configurer avec ton nom de compte) et ton dossier configphp upload, c'est fini.

    Code du php.ini si download t'inquète.

    ! ! ;;;;;;;;;;;;;;;;;;;; ; Language Options ; ;;;;;;;;;;;;;;;;;;;; ! engine = On zend.ze1_compatibility_mode = Off ! short_open_tag = On asp_tags = Off ! precision    =  14 y2k_compliance = On serialize_precision = 100 ! output_buffering = 4096 implicit_flush = Off ! safe_mode = Off expose_php = Off ! ;;;;;;;;;;;;;;;;;;; ; Resource Limits ; ;;;;;;;;;;;;;;;;;;; ! max_execution_time = 120 max_input_time = 60 memory_limit = 128M ! ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;; ; Error handling and logging ; ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;; ! error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED display_errors = On display_startup_errors = Off log_errors = Off log_errors_max_len = 1024 ignore_repeated_errors = Off ignore_repeated_source = Off report_memleaks = On ! ;;;;;;;;;;;;;;;;; ; Data Handling ; ;;;;;;;;;;;;;;;;; ! variables_order = "GPCS" register_globals = Off register_long_arrays = Off register_argc_argv = On auto_globals_jit = On post_max_size = 64M ! magic_quotes_gpc = Off magic_quotes_runtime = Off magic_quotes_sybase = Off ! default_mimetype = "text/html" ! ;;;;;;;;;;;;;;;;;;;;;;;;; ; Paths and Directories ; ;;;;;;;;;;;;;;;;;;;;;;;;; ! enable_dl = On include_path = ".:/usr/local/share/php:/usr/lib/php5/pear" ! ;;;;;;;;;;;;;;;; ; File Uploads ; ;;;;;;;;;;;;;;;; ! file_uploads = On upload_max_filesize = 64M ! ;;;;;;;;;;;;;;;;;; ; Fopen wrappers ; ;;;;;;;;;;;;;;;;;; ! allow_url_fopen = On allow_url_include = Off ! default_socket_timeout = 10 ! ;;;;;;;; ; Misc ; ;;;;;;;; ! date.timezone = "Europe/Paris" ! ;;;;;;;;;;;;;;;;;;;;;; ; Dynamic Extensions ; ;;;;;;;;;;;;;;;;;;;;;; ! extension_dir="/usr/languages/php/5.5.6/lib/php/extensions/no-debug-non-zts-20121212:/usr/lib/php5/20121212/" extension=mysql.so extension=mysqli.so extension=pgsql.so extension=pdo.so extension=pdo_mysql.so extension=pdo_pgsql.so extension=gd.so extension=gettext.so extension=mbstring.so extension=zlib.so extension=curl.so extension=openssl.so extension=mcrypt.so ! ;;;;;;;;;;;;;;;;;;; ; Module Settings ; ;;;;;;;;;;;;;;;;;;; ! [Syslog] define_syslog_variables  = Off ! [SQL] sql.safe_mode = Off ! [ODBC] odbc.allow_persistent = On odbc.check_persistent = On odbc.max_persistent = -1 odbc.max_links = -1 odbc.defaultlrl = 4096 odbc.defaultbinmode = 1 ! [MySQL] mysql.allow_persistent = On mysql.max_persistent = -1 mysql.max_links = -1 mysql.connect_timeout = 60 mysql.trace_mode = Off ! [MySQLi] ! mysqli.max_links = -1 mysqli.default_port = 3306 mysqli.reconnect = Off ! [mSQL] msql.allow_persistent = On msql.max_persistent = -1 msql.max_links = -1 ! [PostgresSQL] pgsql.allow_persistent = On pgsql.auto_reset_persistent = Off pgsql.max_persistent = -1 pgsql.max_links = -1 pgsql.ignore_notice = 0 pgsql.log_notice = 0 ! [Sybase] sybase.allow_persistent = On sybase.max_persistent = -1 sybase.max_links = -1 sybase.min_error_severity = 10 sybase.min_message_severity = 10 sybase.compatability_mode = Off ! [Sybase-CT] sybct.allow_persistent = On sybct.max_persistent = -1 sybct.max_links = -1 sybct.min_server_severity = 10 sybct.min_client_severity = 10 ! [bcmath] bcmath.scale = 0 ! [browscap] browscap = /etc/browscap.ini ! [Informix] ifx.allow_persistent = On ifx.max_persistent = -1 ifx.max_links = -1 ifx.textasvarchar = 0 ifx.byteasvarchar = 0 ifx.charasvarchar = 0 ifx.blobinfile = 0 ifx.nullformat = 0 ! [Session] session.save_path = /tmp session.save_handler = files session.use_cookies = 1 session.name = PHPSESSID session.auto_start = 0 session.cookie_lifetime = 0 session.cookie_path = / session.serialize_handler = php session.gc_divisor    = 1000 session.gc_maxlifetime = 1440 session.bug_compat_42 = 0 session.bug_compat_warn = 1 session.entropy_length = 0 session.cache_limiter = nocache session.cache_expire = 180 session.use_trans_sid = 0 session.hash_function = 1 session.hash_bits_per_character = 5 url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry" ! [MSSQL] mssql.allow_persistent = On mssql.max_persistent = -1 mssql.max_links = -1 mssql.min_error_severity = 10 mssql.min_message_severity = 10 mssql.compatability_mode = Off mssql.secure_connection = Off ! [Tidy] tidy.clean_output = Off ! [soap] soap.wsdl_cache_enabled=1 soap.wsdl_cache_dir="/tmp" soap.wsdl_cache_ttl=86400 ! [spoiler] #!/bin/sh ! export PHP_FCGI_CHILDREN=0 export PHP_FCGI_MAX_REQUESTS=0 ! PHPRC=/home/`id -gn`/cgi-bin/php5.ini export PHPRC ! exec /usr/bin/php-cgi5 [/spoiler] ! En espérant t'avoir aider. Je t'aiderais en privé sinon. !



  • Bonjour,
    J'ai bien fait les modifs mais j'ai toujours la meme version:

    PHP Version : 5.2.13-pl1-gentoo / 32Bit OS

    help… :'( :'(


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.