.htaccess et .htpasswd



  • Bonjour,

    J'ai beaucoup de difficultés à rédiger le .htaccess et le .htpasswd. Je ne parviens pas à trouver la solution sur le net.

    Mon .htacces :

    AuthUserFile /srv/filer02/humanweb01/www/dossier_protect2/mot_de_passe/.htpasswd
    AuthGroupFile /dev/null
    AuthName "Veuillez vous identifier"
    AuthType Basic
    require valid-user

    Et voici mon .htpasswd (placé au bon endroit)

    human:motdepasscrypté

    Le mot de passe est crypté sur OHV. J'ai aussi essayé non crypté.
    Le problème vient-il de mon chemin d’accès au dossier du mot de passe ? J'ai essayé des dizaine de variantes sans succès...

    Lorsqu'on souhaite accéder à une page de mon dossier protégé, on doit remplir l'identifiant et le mot de passe comme prévu, mais après c'est toujours le même message d'erreur :

    *Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@bdsouslesetoiles.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.*

    Si vous avez une idée pour corriger le problème, je vous en serais infiniment reconnaissant !

    Etienne



  • re-bonjour,

    J'ai résolu mon problème en suivant ce tuto à la lettre :
    https://openclassrooms.com/courses/concevez-votre-site-web-avec-php-et-mysql/proteger-un-dossier-avec-un-htaccess

    Contrairement à ce que j'avais pu lire partout ailleurs, il fallait que je crypte le mot de passe avec crypt() et non avec le crypteur OVH.

    ouf



  • Bonjour , je rencontre le meme probleme que toi.

    Mon htaccess est :

    AuthUserFile /srv/filer02/fmalapert3/www/testdesecurite/.htpasswd
    AuthName "Page d'administration protégée"
    AuthType Basic
    Require valid-user

    J'ai crypté avec le scrypte de openclassroom

    fmalapert:mot_de_passe_crypté

    et j'ai tjrs le fenetre d'erreur disant de contacter l'administrateur à saoir moi-même.

    Peux-tu m'aider stp



  • @fmalapert a dit dans .htaccess et .htpasswd :

    J'arrive dorénavant à avoir la fenêtre de connexion mais mon mot de passe ne fonction pas.
    J'ai bien mis le mot de passe en claire en utilisant le script de openclassroom.
    Merci de votre aide



  • Bon , l'erreur venait du fait que je téléchargeais mon htaccess et mon password et que je sauvegardais dans openoffice. Ceci a eux pour effet de me mettre bien dedans.
    Cool ;-)


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.