Problème serveur - PHP: Required non fonctionnel



  • Bonjour à tous !

    Les pages de mon site sont en .php et le début (<!DOCTYPE html jusqu'à la fin de la balise head) est inclut avec required, mais aucune page ne peut-être chargée (Erreur HTTP 500). Cependant, si je mets le début qui était précédemment inclus, (la page a le le début - plus de required), tout fonctionne.

    Tout ceci fonctionne parfaitement en local avec Wamp avec PHP version 5.6.25 (fonctionnel aussi en 7.0.10)et Apache 2.4.23.

    Merci d'avance :)
    Pheon'



  • S’il y a une erreur interne, regardez d’abord les fichiers log : pour les serveurs Linux, la collecte des messages d’erreur se trouve sous /var/log/httpd/error_log. Il est pour cela utile de recharger le site Web pour reproduire l’erreur HTTP 500, tout en observant la création du fichier Log. Vous pouvez ainsi trouver la source de l’erreur assez rapidement. Dans de nombreux cas, les plugins incorrectement programmés ou incompatibles fournissent des messages d’erreur.

    L’erreur peut également se produire si vous n’avez pas défini correctement les autorisations pour les fichiers importants. Il existe généralement trois types de droits :

    Lire (r pour read)
    Ecrire (w pour write)
    Exécuter (x pour execute)
    

    Ces autorisations peuvent être attribuées à trois types d’utilisateurs différents :

    Propriétaire du fichier
    Groupe d’utilisateurs
    Tous les autres

Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.