Encore un petit problème avec le .htaccess et le .htpasswd



  • Alors, j'ai 2 fichiers .htaccess et .htpasswd dans un dossier "admin"

    voici le contenu du fichier .htaccess :

    AuthUserFile /home/Administrateur/www/ptc/admin/.htpasswd
    AuthGroupFile /dev/null
    AuthName "Administration"
    AuthType Basic
    <Limit GET POST>
    require valid-user
    </Limit>
    

    voici le contenu du fichier .htpasswd :

    Administrateur:$1$jARsB8x4$ah.gYL4j5OkCkGh/fREof0
    

    Y a-t-il un problème ?



  • Oui, du moins je pense :

    AuthUserFile /home/Administrateur/www/ptc/admin/.htpasswd
    

    Verifie le path de ton dossier, je pense que ce n'est pas le bon !


  • Administrateur

    Deux chose, à la place de ton login freeheberg, met ton login ftp, ensuite, n'encrypte pas ton mot de passe.



  • Impeccable, merci à vous 2 :-)



  • bonjour.
    j'ai utilisé ce que vous avez dit, mais cela ne marche toujour pas :

    identifiant : xbird
    mdp : bonjour

    lien : http://xbird.freeheberg.com/

    voila ce que j'ai mis dans les fichiers :

    .htaccess

    AuthUserFile http://ns4.freeheberg.com/~xbird/.htpasswd
    AuthGroupFile /dev/null
    AuthName "Administration"
    AuthType Basic
    <Limit GET POST>
    require valid-user
    </Limit>

    .htpasswd

    xbird:bonjour

    comment faut-il faire pour que cela fonctione ?
    comment puije retirer les fichiers que j'ai deja mis, car ils ont diparut.
    j'utilise filezilla.

    merci de me repondre

    *** edit ***
    j'ai essayé avec firefox et internet explorer.


  • Administrateur

    As tu vérifié les chmod que tu as mis sur les fichiers ?

    => Pour voir les fichiers, active "voir les fichiers cachés" dans les options de filezilla.



  • Le chemin vers ton .htpasswd doit être en relatif !



  • ok,
    j'ai changé mes fichiers, mais cela ne marche toujours pas.
    je ne suis pas tres bon en code, alr si vous pouviez m'expliquer pourquoi, cela m'aiderait bcp.

    voici les changement effectues :
    .htaccess

    AuthUserFile /home/xbird/www/.htpasswd
    AuthGroupFile /dev/null 
    AuthName "Administration"
    AuthType Basic
    <Limit GET POST>
    require valid-user
    </Limit>
    

    pour la ligne htpasswd, j'ai utilisé la fonction :

    <?php echo realpath('index.php'); ?>
    

    .htpasswd

     xbird:bonjour
    


  • Essaye ça :

    .htaccess

    AuthName "Administration"
    AuthType Basic
    AuthUserFile "/home/xbird/www/.htpasswd"
    Require valid-user
    

    .htpasswd
    Utilise cette page pour crypter ton mot de passe.
    Tu entre le login et le passe que tu souhaite pour accéder à ta zone protégée, tu copie la ligne obtenue et la copie dans ton .htpasswd.



  • merci bcp, sa marche impecable !

    merci d'avoir aider un noob (^^)



  • je me permet de continuer le sujet, car j'ai exactement le même problème.
    je veux protéger un dossier "admin" avec un .htaccess et un .htpasswd mais évidemment sa ne marche pas.

    Le CHMOD actuel sur le dossier est 705

    Voici ce que contient le dossier .htaccess

    AuthName "Page d'administration protégée"
    AuthType Basic
    AuthUserFile "/home/jaden/www/555/admin/.htpasswd"
    Require valid-user
    

    et ce que contient le .htpasswd

    Jaden:test
    

    Le mot de passe n'est pas crypté car @caaptusss:

    n'encrypte pas ton mot de passe



  • Essaye de crypter ton pass via le lien que j'ai donné pour voir si ça marche.



  • Sa marche une fois que c'est crypté mais sa ne risque pas de poser problème à caaptusss ?


  • Administrateur

    Pas de problème, t'en fait pas :)



  • d'ac

    problème résolu


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.