[Wordpress] Problème sur l'éditeur visuel pour écrire



  • Bonsoir à tous,

    je relate un bug touchant Wordpress sur votre serveur.

    Wordpress version : 2.3.2 FR
    Installation : Aucun problème

    En fait, quand je veux écrire une note, je ne vois pas l'éditeur visuel qui me permet notamment d'éditer mon texte dans ma note.

    A noter que la case "Utiliser l'éditeur visuel pour écrire" est bien coché dans le profil de l'utilisateur (Admin pour le coup).

    De plus, en installant le plugin ''Miwa_Editor_Mu'' me permettant d'avoir une toute nouvelle barre de texte à ma disposition, je n'ai aucun affichage de cette dernière.

    Adress du plugin en question =>
    http://my.sambazen.net/wiki/index.php/En:WPMU_Plugin:Miwa_Editor_Mu
    **
    Pour résumé, quoi que je fasse, je n'ai aucun affichage de la barre de formatage de texte, aussi appelé éditeur visuel.**

    Image de l'éditeur visuel (par defaut):
    http://www.live-cms.com/images/screenshots/wordpress-editor.jpg

    J'ai vidé plusieurs fois le cache Firefox au cas ou, mais rien n'y fait.

    Je n'avais pas eu ce problème lors de l'installation de Wordpress sur un serveur Free par exemple, où tout marchait très bien.

    Dernière chose, à l'accueil du backoffice, ca me redirige quasi-instantanement vers une page de texte brut, rendant l'utilisation de wordpress inutilisable. Mais je crois qu'on a déjà parlé de ce bug sur le forum… sans suite. (pour, momentanement, contrer cette redirection forcé, je me dois d'arrêter le chargement de la page, et rapidement cliquer sur un onglet de l'administration WP).

    Merci pour votre aide,

    HDR.



  • Salut!
    Ca fait plaisir de voir des topics bien ordonnés et sans fautes d'orthographe, parfois :)

    Pour ton problème, si tu utilise l'offre gratuite, il est possible que ce soit le code qui soit responsable de la disparition de ton éditeur. Si c'est le cas (ce que je ne peut affirmer, n'ayant pas wordpress), trois solutions s'offrent à toi:

    • Inscrire ta page d'administration comme étant une page où il ne faut pas afficher les slide-in (pour celà, tu dois te connecter sur l'espace de gestion freeheberg)

    • Souscrire à l'offre no-pubs (voir le topic de "Général" à ce sujet)

    • Attendre la modification du code du slide-in

    Cette dernière option n'étant pas définie précisemment (le code à été changé recemment), je te conseille de te baser sur les deux premières.

    Pour ton problème de texte brut qui s'affiche, est-ce que tu sais précisemment quel est le type de texte (html, javascript, php, …)?

    ++!
    Arcanis



  • Merci de ta réponse. Je prend note, et je vais tester.

    Concernant le texte qui s'affiche après la redirection, il s'agit d'un texte "brut" de type "bloc-note". Le texte est affiché sur 4 lignes environs. La pub est à ce moment la toujours présente.

    Image du bug en question :
    http://pix.nofrag.com/1/a/8/21cc62358df00bdb100cdfbe4c614.gif



  • Je crois que je comprends d'où vient le problème du texte qui s'affiche.
    Si j'ai raison, il est possible que ce bug soit corrigé dans les prochains jours.



  • Inscrire ta page d'administration comme étant une page où il ne faut pas afficher les slide-in (pour celà, tu dois te connecter sur l'espace de gestion freeheberg)

    J'aimerai bien oui, mais je lis ceci dans la partie "Blocage du Slide In" :

    Les pages autorisés ne peuvent être une page principale, ni une page n'étant pas accessible au public (admin protégé).

    Or mon problème se trouve dans la partie Admin de mon site, soit après une page login/mdp.

    Dois-je quand même effectuer ma demande de blocage ? Sachant que ma page ne sera par la suite pas accessible à la vérification du modérateur chargé de contrôler les pages bloquées…

    EDIT: J'ai fait ma demande. Il est indiqué que "le blocage soit immédiat et automatisé une fois validé" mais me pop-up est toujours présent.
    J'attend cependant leur retour.

    PS: C'est dommage qu'on ne peut faire part d'aucun commentaire avec notre demande de blocage. Possible dans un avenir proche ?


  • Administrateur

    Dans le cas des admin wordpress, j'accepte quelques exceptions concernant les pages dites "protégés".

    Concernant les commentaies, je n'y avait pas forcément pensé, j'en prend note.



  • Si je peux rajouter ma pierre à l'édifice pour faire avancer les choses.

    J'utilise un éditeur de texte s'appelant TinyMce (http://tinymce.moxiecode.com/)

    Si je ne me trompe pas, il fait appel à du javascript. Depuis la mise en place de la pub en slide-in, il ne s'active plus lors du chargement de la page d'écriture d'une news.

    Personnelement, ça me derange pas trop et je vais passer en offre gold prochainement. Mais je pense que le problème est identique que pour WordPress. Donc si cela peut vous donner des pistes supplémentaires, c'est avec plaisir :)

    Bon courage pour la suite de votre travail



  • Dans le script du slidein il y a un```
    window.onload



  • Ma demande de blocage du popup pour la page relatif à une nouvelle note dans Wordpress a bien été accepté, mais le problème persiste et reste toujours présent.

    Il y avait en effet 2 slide-in qui intervenaient en même temps sur la page, avec le blocage demandé, cela a bloqué le 1er pop-up, le second est toujours la par contre. C'est un peu comme s'il y avait un system de cadre (et donc 2 pages distincts).. bizarre, bizarre.

    Ma capture d'écran :
    http://pix.nofrag.com/3/4/6/529c9183d63e1af3ff49a8dd7fd67.gif

    C'est quand même embêtant que le service gratuit de Freeheberg ne permet pas l'installation de Wordpress fonctionnel à 100%. Je sais qu'il me suffirait sans doute de passer en mode Gold pour résoudre ce problème, mais je voudrai pouvoir y arriver sans passer par cette case.

    Quelqu'un à une idée de comment résoudre ce problème ?

    @lave> le plugin que j'essaye de faire fonctionner sous wordpress, c'est justement un dérivé de TinyMce. Ceci expliquant donc cela.



  • Salut à tous moi aussi j'ai un gros souci avec mon wordpress

    Voila des que je veus me connecter sur la panel admin enfin plus tot entrer j'ai ma page qui s'affiche pendant secondes max (le temps de chargement de la pub)

    et j'obtient cette erreur (lié au thème)

    http://img204.imageshack.us/img204/2795 … trevy3.jpg

    Si le problème pourait etre corrigé ça serait simpa :)

    ps: et la pub n'est plus repliable, et ce beug est juste sous firefox



  • @emuleman> Salut.

    C'était simplement pour dire que tu remarqueras à la lecture des messages précédents le tien, que le problème que tu soulignes à déjà été évoqué, ainsi que sa réponse.
    Pour résumé, le problème est connu, et devrait disparaitre dans les prochains jours. Tous les utilisateurs de Wordpress ont en effet ce problème.

    Je suis donc tout comme toi dans le même cas et dans l'attente.

    Cordialement.


  • Administrateur

    On va s'y attaquer dans la semaine, on a deux trois choses à faire avant :)



  • @caaptusss:

    On va s'y attaquer dans la semaine, on a deux trois choses à faire avant :)

    Bonjour,
    y a-t-il du nouveau pour ce problème?
    Pour ma part, impossible d'accéder à la section administration de mon site wordpress (et donc d'y poster quoique ce soit…)


  • Administrateur

    Arcanis a commencé à développer un nouveau slide in, il devait le tester sous wordpress pour comprendre d'ou venais le problème.

    Pour le moment, la seule solution est de bloquer les pages via le script de blocage disponible dans l'espace client.



  • Bonsoir,

    Je viens de terminer d'installer Wordpress 2.5.1 sur mon espace perso, et j'ai le meme probleme, certes ce n'est pas genant mais c'est mieux de profiter à fond de Wordpress et de l'editeur Visuel.

    Y a t'il quelque chose de special à effectué ?

    Cordialement

    Jérôme


  • Administrateur

    Pour le moment, pas grand chose.
    Dans quelques semaines, je vais remettre le blocage du slide sur certaines pages. Tu pourras alors libérer ton formulaire.



  • Yes, super !
    Merci encore

    Edit : j'ai bien l'editeur visuel maintenant ;) Merci


Log in to reply